DELL EMC S4112-ON VLT and LACP issue while reloading VLT peer

DELL EMC S4112-ON VLT and LACP issue while reloading VLT peer

One of my customer had problem with DELL EMC S4112-ON switch, so we opened ticket on DELL EMC support, after few days arrived the brand new switch. We did the firmware upgrade to version 10.5.1.2 ( we have same version on second unit), restore configuration to the new unit.

  • Product : S4112F-ON
  • Description : S4112F-ON 12x10GbE, 3x100GbE Interface Module
  • Software version : 10.5.1.2
 

Now is time to installation of the brand new unit, i pluged-in the sfp+ cables, 100 GbE VLT link and powered up the switch. In background was powered on about 30 VM on Hyper-V 2019 and iSCSI connectivity to DELL SC3020 storage. 

When was boot of the new unit done, all hyperv nodes were unavailable, the network goes down, of course that iSCSI network too = all VMs was in state “Paused-Critical”

And why?  There are logs from one of the Hyper-V nodes: 

  • 2:12:18 HPE Ethernet 10/25Gb 2-port 640SFP28 Adapter #2 device detects that the link is up, and has initiated a normal operation. (new unit booted and network card is connected) 
  • 2:12:19 HPE Ethernet 10/25Gb 2-port 640SFP28 Adapter device detects that the link is down. This may occur if the physical link is disconnected or damaged, or if the other end-port is down. (“old unit” was diconnected, and all traffic was disconnected included iSCSI)
  • 2:13:55 HPE Ethernet 10/25Gb 2-port 640SFP28 Adapter device detects that the link is up, and has initiated a normal operation. (after 1 min and some secconds the “old unit” was reconnected

Some logs from new switch: 

This is a big issue in OS10, while reloading your VLT peer all LACP traffic goes down (port-channel) for 1-2 minutes.  

https://www.dell.com/community/Networking-General/S4048-ON-VLT-and-LACP-issue-while-reloading-VLT-peer/td-p/6107971/page/2

UPDATE 17. 3. 2021

With firmware 10.5.1.4 was problem with VLT and LACP issue while reloading VLT peer fixed. Name of fix is: AR-36952. Please update your OS10 switches to latest 10.5.1.4 firmware. I dont have experience with updating to latest firmware and i think, that update is WITH DOWNTIME. More info coming soon. 

(Visited 70 times, 1 visits today)

Napsat komentář

Vaše e-mailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *